Skip to content

How To: Program a Cisco Router for T1 to Ethernet Handoff

by Jon on November 30th, 2009

This is a quick configuration for a Cisco router if you have a T1 smart jack and need an Ethernet connection. In order to program the router you will need the console cable that plugs into a serial port on the computer and the console port on the router. Then open up hyperterm and use the following settings: 9600 – 8 – none – 1 – none. Then you will be asked for your password to login to the console, enter that and then use the command “enable” to get into enable mode which will ask for another password. Enable mode grants permission to make changes to the router configuration. Next use the command “configure” to get into the configuration. Now enter in the following commands to use this sample config replace the ip addresses with your own.

Router1(config)# service udp-small-servers
Router1(config)# tcp-small-servers
Router1(config)# hostname myoffice
Router1(config)# enable secret yourpassword
Router1(config)# ip subnet-zero
Router1(config)# ip domain-lookup
Router1(config)# ip name-server 200.66.7.199 200.66.8.199
Router1(config)# interface Ethernet0
Router1(config-if)# ip address 111.10.33.11 255.255.255.248
Router1(config-if)# exit
Router1(config)# interface Serial0
Router1(config-if)# description My Company T1
Router1(config-if)# encapsulation ppp
Router1(config-if)# ip address 110.22.137.122 255.255.255.252
Router1(config-if)# exit
Router1(config)# ip http server
Router1(config)# ip classless
Router1(config)# ip route 0.0.0.0 0.0.0.0 Serial0
Router1(config)# line con 0
Router1(config-line)# password yourpassword
Router1(config-line)# login
Router1(config-line)# exit
Router1(config)# line aux 0
Router1(config-line)# line vty 0 4
Router1(config-line)# password yourpassword
Router1(config-line)# login
Router1(config-line)# exit
Router1(config)# exit
Router1# write

From → Cisco

One Comment
  1. This update was really interesting, how often do you update your blog? I’ve bookmarked this site and gave you guys a digg, hope to read more soon!

Leave a Reply

Note: XHTML is allowed. Your email address will never be published.

Subscribe to this comment feed via RSS

%d bloggers like this: